k2pdfopt的使用经验

-odpi 简单的理解是你要在电子书上每行显示多少个字,眼睛不太好的 可以把参数后面的数字调大点。

-ls 横向模式,横排的pdf也可以采用横向模式,比如有些行有文字有图的情况。

-as 自动旋转,扫描文件不正时选用,增加耗时,但是效果好。
-m 提前切边,可以用-mt/b/l/r分别指定上下左右裁边,适合扫描文件正文四周不干净,比如有页眉、页脚或书脊阴影的情况,减少对正文干扰。

例:-ml 1 -mr 1 -mt 1 -mb 1 意思是只选取距离上下左右1cm的内容重排。

-w 和 -h 输出高宽,默认为k2的六寸,560x735。

-ws 0.001 或 0 字符间距,最重要参数,这样就不会出现默认的过大空格、乱断行的情况,适用于汉字的重排。

-bp 自己琢磨出来的。目的是消除原始分页带来的空隙。

bp+ 就是强制每一页单独重排,两页不会排在一起。

-gtr 目的防止扫描质量不好的文本的行行之间粘连。

-ds 有时候页面尺寸显示太小了,就要增加-ds后面的参数,比如1.6。

 有的书比普通书籍页面大了50%多,用ds来缩小文档页面,比如-ds 0.5,这样才能让  
 k2pdfopt正确重排,不会出现一些奇怪的问题。  

-col 可以对多栏的页面分栏重排,对文字多的页面用的比较多。

-grid 可以按照网格n X m 来分割页面,对图片型pdf比较有用。

-cbox 这个参数可以理解为按需分割页面的任意部分。比如我只要页面的中间部分,其他不要。

多个-cbox的组合就可以分割出(挖出)你想要页面组合,这个参数比-grid参数更灵活精确。  
  -cbox -<left>,<top>,<width>,<height> -left 距离页面左边距离  
  -top 距离页面上面距离  
  以上两个参数形象的讲是格子的左上坐标  
  -width -height 是格子的大小  
  要将pdf文档分成几个格子 就要有几个格子的参数  

-de 忽略微小瑕疵。

-g 加深字体。

-wt 这个参数简单的说是可以“颠倒黑白” (数值0代表黑 255代表白)
-wt 10 相当于如果像素的“黑”度是10,那么把这个像素认为是白色(即不参与重排), 这个参数对于有背景色或者水印的扫描pdf重排非常有用。
例如:-wt+ 10

一些例子:
最重要的四个参数,一般中文书籍用这四个参数就够了

-ds 0.9 -odpi 200 -ws 0.001 -bp 0.1  

@BookWorms

-odpi 140 -ws 0.001 -bp + -m 0.1 -x  
-odpi 160 -ds 0.9 -ws 0.001 -bp + -col 1 -de 3 -m 0.1 -mt 0.3 -mb 0.2  

@dellx51

-bp 0.1 -gtr 0.021 -ds 1.15  

扫描二维码,在手机上阅读!

[转载]国外主机的机房线路选择

原URL:https://axmemo.com/internet/how-to-select-vps-service.html

我纠结了好久要不要发这篇文章,因为自己前前后后在国外开了N台主机,不过好在拥护祖国统一坚定社会主义核心价值观,没做什么坏事,所以一直相安无事。我就害怕这篇帖子一发就被系统AI侦测到了,然后我就GG了~

我最早用的是国外的虚拟主机服务,选择的是Lunarpages的虚拟主机服务,好处就是自带后台控制面板,登录上去配置一下,把文件放过去就能跑起来。不过缺点就是有时候会卡,而且整体费用并不算便宜。

后来国外的VPS服务商越来越多,所以就想着自力更生换这个试试看,不过好在自己也算是工科出生,一些基本的Linux语句也难不倒咱,所以也就慢慢上手了。而且网上有很多小伙伴编写了一键安装的脚本,很多时候你按部就班输入指令就可以了。所以,其实更复杂的是不同服务器之间的数据迁移操作。

基本上国外数的出来的VPS服务商都有涉猎,包括最早的Linode,Vultr,DO…最近又出了不少的新主机服务商,反正抱着不折腾会死的态度,也多多少少尝试了一些。下面是一些自己折腾的心得,和大家分享一下。

大的VPS服务商是最好的选择:

前前后后买过不少VPS服务商,结果最后我还是回到了大服务商的怀抱。很多小服务商一开始开出很低的价格,而且测试的时候性能很好,但是一分钱一分货的道理是亘古不变的。等到后来超售了,你就马上GG了。亦或者是没有超售,小服务商的整体出口也是非常有限的,等到高峰期的时候,马上就被壅塞了。所以,买的时候好,不代表后面一直会好。而且,小服务商的退款流程一般都非常麻烦。一个亲身经历典型案例,就是一家叫做Enoctus的商家,推出了HK的主机,一开始性能好到爆炸。后来就被DDOS了,然后IP也改了,性能也差了,要退款也没门了。我就当是那个主机喂了狗了。

另一方面,大的主机服务商一般都有较多的IP资源,然后你如果真的不幸连累被封了,一方面可以开Ticket去申请更换,另一方面你也可以付费进行更换。所以说嘛,要遵纪守法,坚守社会主义核心价值观就没错了。

根据自己的需要购买硬件配置:

首先,你要明确自己的主机是用来做什么用的,每个月需要多少的流量以及日常有多少的访问用户,然后根据这个来选择购买主机的配置。当然,如果你有钱可以完全略过我说的这一段。然后你可以在购买完主机之后,进行系统的跑分测试,没错,就是不服跑个分。然后平时有空也可以去看看系统负载情况。之所以选择大的主机服务商,就是因为他们会提供非常方便的系统扩容,以及迁移的服务。如果真的性能不够了,直接在后台可以无痛的扩容。嗯?无痛是一个什么情况?谁说无痛了,钱包还是会痛的。

选择合适自己的网络接入线路:

其实到最后才是本文要说的关键,其他乱七八糟的机房类型我就不说了,还是直接说说我手上用的几个机房数据好了。我手上有GIA.CN2、CN2、QN、MC等多个机房。其中最有名的应该就是CN2机房了,GIA.CN2可以认为是CN2的白金版。而QN机房的一些链路也和CN2一样所以差别不大,MC机房则相对会有些变化。当然这个变化可能是因为主机服务商的不同所导致的。我手上的不同网络线路都位于不同的服务商手上。

我们以BandwagonHost为例,我们在后台可以看到他有多个DC可以提供切换,当然切换机房只适用于基本套餐,某些特殊套餐是指定特定机房的(例如:定制版的QN机房是无法切换到其他DC去的)。我们常用的机房包括:

DC2:QN机房
DC3:CN2机房
DC4:MC机房
DC8:CN2机房
DC9:CN2.GIA机房

你可以根据自己的实际情况,来切换不同的机房。就拿CN2来说,DC3和DC8在不同省分的电信接入响应情况并不相同。像浙江来看,DC8的速度会快很多。不过DC3,DC8的线路的移动接入速度都不是特别满意。反倒是DC2的QN机房的某些移动响应更好一些。

所以,综合来看选择QN机房是一个性价比比较高的选择,而CN2机房的话要看实际使用情况了,当然如果你有钱直接选择CN2.GIA机房的话,一定效果更好。当然如果你更有钱,可以选择HK的机房,那样的话你简直会爽到飞起。当然,你的钱包也会爽到飞起。

不过最后要说一句的是,似乎同样的配置,DC3机房的硬盘性能要比DC8好不少,不过因为现在Bandwagon迁移机房都是指定IP了,所以可能这是某台服务器的个体情况也说不定。反正GIA的数据是漂亮的不得了,说到最后还是那句话:一分钱一分货。


扫描二维码,在手机上阅读!

Windows 7修改静态路由表的跃点数

显示当前网关:

route print
netstat -r //两个命令都是显示所有的静态路由表
route print -4 //只显示IPV4的网关
route print -6 //只显示IPV6的网关

添加网关:

route add 0.0.0.0 mask 0.0.0.0 192.168.1.1

删除网关:

route delete 0.0.0.0 mask 0.0.0.0 192.168.1.1

修改静态路由的跃点数有两个方法:

1.使用命令:

route add 0.0.0.0 mask 0.0.0.0 192.168.1.1 METRIC 2

添加跃点数为2的网关

route change 0.0.0.0 mask 0.0.0.0 192.168.1.1 METRIC 1` 

将指定网关的跃点数修改为2

2.通过连接属性:

打开“网络和共享中心”,找到“更改适配器设置”,打开“本地连接”的属性,选择“Internet协议版本4”的属性,然后在弹出的页面的右下角找到“高级”,这里会出现一个“自动跃点数”,将“自动跃点数”前的勾去掉,修改成一个数字,如2,跃点数的值越小,就越优先使用这个网关,自己根据需要进行修改一下。


扫描二维码,在手机上阅读!

Increase the font size in FF57 toolbars and menus

Increase the font size in the FF57 toolbars and menus

Global Zoom Factor

This will enlarge both the toolbar area and the content area:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button accepting the risk.

(2) In the filter box, type or paste pix and pause while the list is filtered

(3) Double-click layout.css.devPixelsPerPx and change its value to 1.25 and click OK, which corresponds to 125% font size in Windows display settings. The toolbar area should enlarge after a few moments. Too small? Try 1.5 and see whether that suits you better. And so on. If you are on Mac and use a Retina display, anything below 2.0 may be smaller than what you started with, so start with 2.0.

Important: Do not go below 1.0 because it may become too tiny to edit.


扫描二维码,在手机上阅读!

DHCP snooping

一、DHCP snooping 技术介绍

DHCP监听(DHCP Snooping)是一种DHCP安全特性。Cisco交换机支持在每个VLAN基础上启用DHCP监听特性。通过这种特性,交换机能够拦截第二层VLAN域内的所有DHCP报文。

通过开启DHCP监听特性,交换机的非信任端口只能够发送DHCP请求,丢弃来自非信任端口的所有其它DHCP报文,例如DHCP Offer报文等。而且,并非所有来自非信任端口的DHCP请求都被允许通过,交换机还会比较DHCP请求报文的(报文头里的)源MAC地址和(报文内容里的)DHCP客户机的硬件地址(即CHADDR字段),只有这两者相同的请求报文才会被转发,否则将被丢弃。这样就防止了DHCP耗竭攻击。

信任端口可以接收所有的DHCP报文。通过只将交换机连接到合法DHCP服务器的端口设置为信任端口,其他端口设置为非信任端口,就可以防止用户伪造DHCP服务器来攻击网络。

DHCP监听特性还可以对端口的DHCP报文进行限速。通过在每个非信任端口下进行限速,将可以阻止合法DHCP请求报文的广播攻击。DHCP监听还有一个非常重要的作用就是建立一张DHCP监听绑定表(DHCP Snooping Binding)。一旦一个连接在非信任端口的客户端获得一个合法的DHCP Offer,交换机就会自动在DHCP监听绑定表里添加一个绑定条目,内容包括了该非信任端口的客户端IP地址、MAC地址、端口号、VLAN编号、租期等信息。

二、DHCP snooping 配置

Switch(config)#ip dhcp snooping                     

打开DHCP Snooping功能

Switch(config)#ip dhcp snooping vlan 10,20         

设置DHCP Snooping功能将作用于哪些VLAN

Switch(config)#ip dhcp snooping verify mac-adress                 

检测非信任端口收到的DHCP请求报文的源MAC和CHADDR字段是否相同,以防止DHCP耗竭攻击,默认为开启

在接口模式下:

Switch(config-if)#ip dhcp snooping trust            

配置接口为DHCP监听特性的信任接口,所有接口默认为非信任接口

Switch(config-if)#ip dhcp snooping limit rate 15  

限制非信任端口的DHCP报文速率为每秒15个包(默认即为每秒15个包)
如果不配该语句,则show ip dhcp snooping的结果里将不列出没有该语句的端口,可选速率范围为1-2048

Switch(config)#errdisable recovery cause dhcp-rate-limit                 

使由于DHCP报文限速原因而被禁用的端口能自动从err-disable状态恢复

Switch(config)#errdisable recovery interval 30

设置恢复时间;端口被置为err-disable状态后,经过30秒时间才能恢复

Switch(config)#ip dhcp snooping information option                 

设置交换机是否为非信任端口收到的DHCP报文插入Option 82,默认为开启状态

Switch(config)#ip dhcp snooping information option allow-untrusted                

设置汇聚交换机将接收从非信任端口收到的接入交换机发来的带有选项82的DHCP报文

Switch(config)#ip dhcp snooping database flash:dhcp_snooping.db                 

将DHCP监听绑定表保存在flash中,文件名为dhcp_snooping.db

Switch#renew ip dhcp snooping database flash:dhcp_snooping.db         

特权级命令;立即从保存好的数据库文件中读取DHCP监听绑定表。


扫描二维码,在手机上阅读!

Cisco 3602 AP 配置记录

en

conf t

ip domain-name NOKIA.COM
no ip name-server
clock timezone BeiJing 8
ip name-server 114.114.114.114
ip domain-lookup

hostname Cisco3602_201

enable secret tvb1999
username Cisco password tvb1999

dot11 ssid CiscoWiFi
authentication open
authentication key-management wpa version 2
guest-mode
wpa-psk ascii 0 Aa123456

dot11 ssid CiscoWiFi-5G
authentication open
authentication key-management wpa version 2
guest-mode
wpa-psk ascii 0 Aa123456

interface Dot11Radio0
encryption mode ciphers aes-ccm
ssid CiscoWiFi
no shutdown
bridge-group 1

interface Dot11Radio1
encryption mode ciphers aes-ccm
ssid CiscoWiFi-5G
no shutdown
bridge-group 1

interface GigabitEthernet0
bridge-group 1

interface BVI1
ip address 192.168.1.201 255.255.255.0

ip default-gateway 192.168.1.1

ip http server
no ip http secure-server
line vty 0 4

sntp server 202.120.2.101


扫描二维码,在手机上阅读!

思科交换机部分学习笔记

1:配置登录用户、口令、时间等

Switch> //用户直行模式提示符
Switch>enable //进入特权模式 简化命令en
Switch# //特权模式(配置密码后必须输入密码才可进入特权模式)
Switch#config terminal //进入全局配置模式 简化命令conf t
Switch(config)# //配置模式提示符
Switch(config)#hostname 3750E //设置主机名成为3750E
3750E(config)#clock timezone GMT 8 //设置时区
3750E(config)#ntp server 211.233.40.78 //设置NTP服务器地址
3750E#show clock //显示交换机当前时间
3750E(config)#no ip domain lookup //关闭域名查询,如果不关掉的话,错误的命令可能引起查询而卡

3750E(config)#line con 0
3750E(config-line)#logging sync //防止输入信息被调试信息打断

3750E(config)#enable password xxx //设置使能口令为明文显示为xxx
3750E(config)#enable secret xxx //设置使能口令为密文显示为xxx 这个密码优先级高于上面的那个

3750E(config)#line vty 0 15 //设置虚拟终端线,通过telnet方式,登录允许0-15个用户同时登录
3750E(config-line)#login //设置远程telnet远程登录验证
3750E(config-line)#password xxx //设置telnet登录密码

2:vLan设置

3750E>enable //进入特权模式 简化命令en
3750E(vlan)#vlan 2 //创建vlan 2
3750E(vlan)#name xxx //并给vlan2命名
3750E(vlan)#no vlan 2 //删除vlan 2
3750E(vlan)#exit //回到特权模式下

3:端口设置命令

3750E(config)#ip routing //运行路由协议,让每个vlan间实现通信
3750E(config)#switchport //转换为2层端口
3750E(config)#no switchport //转换为3层端口
3750E(config)#interface giga3/0/1 //进入网口1 简化命令int g3/0/1
3750E(config-if)# //接口视图模式
3750E(config-if)#shutdown //停用当前端口
3750E(config-if)#no shutdown //启用当前端口 简化命令no sh
3750E(config-if)#
3750E(config-if)#duplex auto/full/half //设置端口工作模式为 自适应/全双通/半双通
3750E(config-if)#switchport mode trunk //设置当前端口模式为汇聚 简化命令sw mode trunk
3750E(config-if)#switchport mode access //设置当前端口模式为接入
3750E(config-if)#switchport trunk allowed vlan 1,2 //设置当前汇聚端口允许vlan1,2通过,vlan修剪,默认为all,全部允许
3750E(config-if)#switchport trunk vlan 2 //设置当前汇聚端口允许vlan 2通过
3750E(config-if)#switchport access vlan 2 //将当前端口加入到vlan 2中
3750E(config-if)#switchport trunk encap dot1q //设置vlan中继

4:将单个端口加入vlan 2中

3750E(config)#interface giga3/0/1
3750E(config-if)#switchport mode access
3750E(config-if)#switchport access vlan 2

5:将多个端口加入到VLAN 2中

3750E(config)#interface range giga3/0/1 - 10 //简化命令 int ra giga3/0/1 - 10
3750E(config-if-range)#switchport mode access
3750E(config-if-range)#switchport access vlan 2

6:设置VTP

3750E(config)#vtp domain xxxx //设置发vtp域名
3750E(config)#vtp password xxxx //设置发vtp密码
3750E(config)#vtp mode server //设置发vtp模式为 vtp服务器
3750E(config)#vtp mode client //设置发vtp模式为 vtp客户端

7:为vlan1的虚接口配置IP地址

3750E(config)#interface vlan 1 //进入vlan 1 简化命令 int vlan 1
3750E(config-if)#ip address 192.168.0.100 255.255.255.0 //设置ip地址
3750E(config)#ip default-gateway 192.168.0.5 //设置默认网关
3750E(config)#end //退出当前模式

8:交换机保存设置命令

3750E#write //保存配置信息
3750E#copy running-config startup-config //将当前正在使用中的配置保存到交换机开机需要加载的配置文件里去

9:交换机显示命令

特权模式下:
3750E#show vtp //显示vtp配置信息
3750E#show run //显示当前配置信息
3750E#show running-config //显示当前正在使用的配置信息
3750E#show startup-config //交换机开机是自动加载的 配置文件
3750E#show vlan //显示vlan配置信息
3750E#show interfaces //显示端口配置信息 (输出信息太多 不建议使用)
3750E#show interfaces g3/0/1 switchport //显示二层端口状态,可以用来决定此口是否为二层或三层口
3750E#show int g3/0/1 //查看指定端口配置信息
3750E#show ip int vlan 100 //查看vlan100的ip配置信息
3750E#show boot //查看交换机启动镜像
3750E#show version //查看交换机固件版本信息

10:基于端口的mac地址绑定

3750E#config terminal //进入配置视图模式 简化命令 conf t
3750E(config)#interface giga3/0/1 //进入具体端口视图模式下
3750E(config-if)#switchport port-secruity //配置端口安全模式
3750E(config-if)#switchport port-security maximum 1 //限制该端口下可用的mac地址数量为1个,防止私接交换机
3750E(config-if)#switchport port-secruity mac-address MAC(主机的mac地址) //配置该端口要绑定的主机的MAC地址
3750E(config-if)#no switchport port-secruity mac-address MAC(主机的mac地址) //删除绑定主机的mac地址

11:端口汇聚

3750E(config-if-range)#channel-group 1 mode ? //查看本机端口聚合可以使用的协议
3750E#show int po1 //查看1组的聚合信息
3750E(config)#int po1 //进入1组进行设置
3750E(config)#no int po1 //删除etherchannel 1
3750E#show etherchannel summary //可以看到绑定了多少接口 简化命令show et su
3750E#show etherchannel detail //查看端口汇聚详情 简化命令show et de
3750E#show etherchannel port-channel //查看汇聚状态下的端口情况 简化命令show et port
3750E#Show interface etherchannel //查看端口汇聚状态 简化命令show int et

A:配置2层端口汇聚

sw1(config)#int ra g3/0/1 - 2
sw1(config-if)#channel-protocol pagp/lacp
sw1(config-if)#channel-group 1 mode on/deseriable/auto

sw2(config)#int ra g3/0/1 - 2
sw2(config-if)#channel-protocol pagp/lacp
sw2(config-if)#channel-group 1 mode on/deseriable/auto

B:配置3层端口汇聚

sw1(config)#int ra g3/0/1 - 2
sw1(config-if)#no switchprot
sw1(config-if)#channel-group 1 mode on
sw1(config)#int po1
sw1(config-if)#ip address 192.168.5.1 255.255.255.0
sw1(config-if)#end

sw2(config)#int ra g3/0/1 - 2
sw2(config-if)#no switchprot
sw2(config-if)#channel-group 1 mode on
sw2(confif)#int po1
sw2(config-if)ip address 192.168.6.1 255.255.255.0
sw2(config-if)end

12:DHCP功能

Switch(Config)Ip Dhcp Pool Test01 //设置地址池的名字
Switch(Config-pool)Network 192.168.2.0 255.255.255.0 //设置该子网的地址池
Switch(Config-pool)Dns-server 192.168.2.10 //设置该子网的DNS服务器
Switch(Config-pool)Default-router 192.168.2.1 //设置该子网的网关
Switch(Config)Ip Dhcp Excluded-address 192.168.2.2 192.168.2.10 //设置dhcp保留不分配的地址。
3750E#show ip dhcp pool //显示dhcp地址池信息

13:配置交换机的snmp功能

3750E(config)#snmp-server community xxx ro //xxx为自定义的共同体名称,并且团体的权限为只读。
3750E(config)#snmp-server trap-source giga3/0/1 //设置snmp监控的端口,此端口必须要配置IP地址才行
3750E(config)#snmp-server trap-source vlan 1 //把vlan 1接口作为监控端口
3750E(config)#snmp-server host x.x.x.x(ip地址) xxx(团体名) //设置管理机x.x.x.x,同时允许该管理机以团体名xxx访问
3750E(config)#snmp-server host 192.168.1.88 zy //例子
3750E(config)#snmp-server enable traps //启用snmp服务

14:清空设置

3750E# write erase
Erasing the nvram filesystem will remove all files! Continue? [confirm]y[OK]
Erase of nvram: complete
3750E#
3750E# reload
System configuration has been modified. Save? [yes/no]:n

15:清空vlan配置

要删除vlan设置,删除vlan.dat即可。


扫描二维码,在手机上阅读!

【转贴】浑圆桩和塌腰的秘密

很多朋友都站浑圆桩,但是见了面看到的,没有一个站对的,最大的问题是“含胸”。无论站桩还是打拳,中线要正直是最根本的,不然任脉督脉中脉如何正常运行?含胸的概念太误人,凡是认为胸要含起来的,都会站成佝偻背,前任后督都是弯曲的,时间长了身体会出问题的。这不是小问题,而是个严重的问题。

想教给别人,首先自己得先练对了,而且在自己身上有了验证,否则误教误学,人家练出毛病来,是要承担因果的。一个最基本的涵胸拔背就这么多人搞错;还有那个塌腰,如今也成了秘密,真是令人无语。

站浑圆桩得先站直溜了,一条垂直线不能丝毫含糊。虚灵顶劲和塌腰是一对劲,是为了把脊柱关节层层拉开。涵胸拔背也是一对劲,左右肩膀横向拉开,稍微向后,两片肩胛骨有相贴之意,而后放松肩膀,也即所谓沉肩,这样肩关节才能打开。胯骨横抽,再坐胯,才能打开胯关节。这几个地方没打开,练不出真东西。

中线笔直,后脑勺-尾椎骨-脚后跟一条线,这是最基本的姿势要求。呼吸以踵的意思,很多人不明白。按照上面说的规矩站好了,重心放在脚后跟,内里的呼吸带动气血运行,都是从脚跟开始的,这就是所谓的秘密。你站得前仰后合的,气血走得就不对了。所以,形意拳讲究九要,规矩差一点都不行,错了就出问题。

肩膀打开了,胸部也就最大程度地自然打开,这个才是“涵”胸。有容乃大,往里头一瘪,说不好听话那是在慢性自杀。后面中线笔直,前面做到涵胸了,即所谓前虚后实,一呼吸自然入丹田,也就做到了下实上虚,身体的阴阳分得才清楚。道家的东西就是揽阴阳为我所用,身体里虚实不分,如何去炼这个阴阳呢?

身上姿势对了,双手一环抱,尽量成圆,掌心对着自己胸部,五指自然分开成势。膝盖微微下蹲,蹲到什么程度?全身感觉浑圆了就成,这就是浑圆桩的根骨所在。你按照我说的要求都站对了,慢慢往下蹲,全身有了圆球一体的感觉,这个时候刚刚好。有的门派有高中低姿态各种浑圆桩,系为练拳所设,彼道非吾道。

正确的塌腰,是命门以下区域整体向下沉,与头顶上领是一对相反的劲。塌腰做对了的,自动提肛,肛门自动就封上了,不是你自己做作地去关上。自动提肛,海底穴与百会穴遥遥呼应,这个才是做到了真正的提肛。以此做到了中线笔直,上中下丹田就在一条线上,气路才真正畅通。这点很重要,也是天大的秘密。

站桩也是实际功夫,从一开始几十分钟到最后几个小时,按照三年来计划,不需要急功近利。只要站对了,身体里马上就有反应。站一次有一次的收获,练一天有一天的进步。自己得了真实好处,就能长期坚持,不然就不是真东西。站桩有了所得,可以配合打坐,再加上一套太极拳,这辈子健康长寿的足够用了。

武术是一种生活,或者说是生活的组成部分,武术需要练,其实也是研究。我们学习一个门派的功夫,更多的是钻研其内在,这个乐趣才大。内家拳是道家性命双休的东西,练对了就给你带来身心上实实在在的好处。没得着好处的,肯定是没练对。

放松,是在间架正确基础上的放松,不然就是松懈,毫无用处。间架正确了站得太紧也不行,所以它两个是辩证关系,不能偏废任何一头。内家拳修身养性,练出真东西来的肯定是德行高深之人。如今找明白师傅不易,应先看其人品、气度和涵养,绝无偏差之理。入门要从最基础的开始练起,好高骛远的绝无成就。

做不到一下子就无思无欲无形无相的,也不要气馁,绝大多数人都差不多的,不妨就去老实念佛。等到以一念能代万念时,自然也就清静了。且念佛都有感应。人都想求功能,切不可去搞那些怪力乱神的东西,只要念佛到一心至诚处,自然该来的都来。站站桩,练练拳,念念佛,真想不出来还有比这些更实际的了。

人生最大的快乐来自于真正的清净,无论打坐还是站桩,亦或是行拳,真到了一尘不染的时候,那个清净和快乐就来了。几乎所有人都没那个本事修到吕洞宾那样,所以就老老实实把人做好,然后行一些实际的功夫。活着时健康,死了转生极乐,这条路既现实又有保证,比每天做着大罗金仙的梦安全多了。

看到太多的人对气脉、功能、身体里的景象感兴趣。如果我现在告诉你,那是条不归路你信吗?这个身体是个工具,用完了是要扔掉的,连释迦摩尼最后也都要走这条路,我们为什么那么执着,就一定要做到即身成就呢?没有遇上好的机缘,是不好随便发春梦的,练出问题可不象遛弯那样随便可以回头,要谨慎从事。

带着有所得的心去修无为法,如同买几十块钱水果去庙里求神佛菩萨保佑发大财升大官全家幸福安康,有用吗?那个专门去烧香的回来路上出车祸死全家。你带着成仙的梦整天去搞气脉,搞五眼六通。今天这里动了,明天那里热了,告诉你,都是欲望之心的显现,不过是换了张面孔而已。所以,未见本心,修法无益。

做人要脚踏实地,修行也是一个道理。首先得解决生理和心里健康的问题。满身病气,满脸乖戾,是没法修行的。如果你见到这样一个所谓的大师,赶紧躲远点。身心绝对健康了才能进一步往下走,不然都是痴心妄想,过于执着的人最后就把自己害死了还不自知,免不了地狱走一遭。千修行万修行,都不如把人做好。


扫描二维码,在手机上阅读!

华硕路由器刷固件的三清

看到太多太多的机油问,刷完Merlin或者小宝固件需要三清吗?

  1. 点网页里的恢复出厂值按钮(Reset),进行恢复初始设置(SW Reset,软件恢复出厂值)。
  2. 正常开机状态,按硬件的Reset按钮,看到电源灯慢闪5下后放开,路由器进入恢复初始值状态(HW Reset,硬件恢复出厂值)。
  3. 当固件损坏,或者无法正常开机时,按硬件的WPS按钮,上电开机,看到电源灯快闪5下后放开,路由器进入恢复初始值状态。

上面说的只是三种不同方式的恢复出厂值而已,我们看到第三种相对来说比较测试,是由底层硬件促发的。
而且当固件无法进入的时候,reset按钮也是无效的,此时就可以用这种方式。

所以华硕路由器刷固件没有三清的说法,这是华硕路由器三种恢复出厂值的方式。


扫描二维码,在手机上阅读!

qiye:经行与静坐

多年前,读南师的书,自己学着盘腿静坐,时间长了,渐渐感觉腿上身上酸疼难耐,实在熬不下去的时候,找到南师门下的亲证师和法光师请教,得法师指点,才知道佛门最好的对治方法就是经行。简单说就是甩开膀子大步向前行走,活动腿脚舒经活络,既利于养生又利于修道,这对学人无疑是一举多得的大方便法门。

剪辑了两段南怀瑾老师在《南禅七日》中关于经行的视频:

优酷:视频1 http://v.youku.com/v_show/id_XMzgwNTY3NjMy.html

优酷:视频2 http://v.youku.com/v_show/id_XMzg2ODgzMzA0.html

刚刚百度了一下“经行”,大致解说如下,学人可以参考。

详细释义 ----- 佛教徒因养身散除郁闷,旋回往返于一定之地叫“经行”

静坐和经行

静坐和经行都是佛门修持禅定和智慧消除心的贪欲、嗔恨、愚痴缺陷的具体方法。静坐是在静中修定慧,经行是在动中修定慧,两者交替进行。从经律中可以发现,佛在世时对此两者同样重视,甚至在修智慧时经行的修法更有胜于静坐之处。可惜经行的修法为我国的佛教徒所轻视失传了很久了。

经行的要点

经行中不可专注于意守一处,而是自然的知道、觉知。如:呼吸,身体的某一部位,此法对强迫症很是实用;若经行中观察身、受、心、法,观察人生宇宙的自然现象则是在修智慧,也就是佛中所说的观照。经行中可以调节身体,也可以消除众多烦恼获得身心的清净安乐,大得可以体验整个世界,微细时可以观察组成身心的最微小的微粒和心念的真相,也可以体验每一刹那中物质与精神的众多生灭变化。其中的利益不是亲身实践的人所容易理解并获得的。

相关解释

慈恩解云。西域地湿。叠砖为道。于中往来。如布之经。故曰经行于一定之地旋绕往来也。即坐禅而欲睡眠时,为此防之,又为养身疗病。玄赞二曰:‘西域地湿,叠塼为道。于中往来,消食诵经。如经布绡之来去,故言经行。’

据《大比丘三千威仪经》卷上所载,适于经行之地有五,即闲处、户前、讲堂之前、塔下、阁下。

另据《四分律》卷五十九所说,时常经行能得五利:(一)能堪远行,(二)能静思惟,(三)少病,(四)消食,(五)于定中得以久住。

寄归传三曰:‘五天之地,道俗多作经行。直去直来,唯遵一路。随时适性,勿居闹处。一则痊痾,一能销食。(中略)若其右绕佛殿,旋游制底,别为生福,本欲虔恭。经行乃是销散之仪,意在养身疗病。旧云行道,或曰经行。二事总包,无分泾渭。遂使调适之事久阙东川。’

十诵律五十七曰:‘经行法者,比丘应直经行,不迟不疾。若不能直,当画地作相,随相直行,是名经行法。’

摩得勒伽六曰:‘比丘经行时,不得摇身行,不得大驶驶,不得大低头,缩摄诸根,心不外缘,当正直行。行不能直者安绳。’

《四分律》卷五十云(大正22·938a):

‘时诸比丘露地经行,患风雨日曝得患。佛言︰听作经行堂。不知云何作?佛言︰听长行作。作堂所须一切给与。时彼上座老病羸顿,经行时倒地。佛言︰听绳索系两头循索行。捉索行手软破手。佛言︰听作卷若竹筒,以绳穿筒手捉循行。经行时疲极,听两头安床。’

《四分律》卷五十九谓︰(1)堪远行,(2)能思惟,(3)少病,(4)消食,(5)得定久住。

经行是直行,与右绕佛塔的修福有差别。《南海寄归传》卷三说右绕佛殿,旋游制底,别为生福,本欲虔恭;经行乃是销散之仪,意在养身疗病。


扫描二维码,在手机上阅读!

最新文章

最近回复

分类

归档

其它